[Date Prev][Date Next][Thread Prev][Thread Next]
- Subject: luaL_ prefix in lauxlib.h
- From: Fabien <fleutot+lua@...>
- Date: Wed, 17 Nov 2010 10:23:17 +0100
Hi, let's start suggestions for Lua 5.3 :)
the functions provided by lauxlib.h generally have quite generic purposes, yet have a luaL_* prefix instead of lua_*. I realize it might have made sense when lauxlib was a fresh addition, but from a usability point of view, I don't see what I get in exchange of having to remember which function starts with luaL vs. which one starts with just lua.
Are there reasons to keep this that way, apart from backward compatibility concerns which could be addressed through a set of macros?