[Date Prev][Date Next][Thread Prev][Thread Next]
- Subject: Re: luaL_ prefix in lauxlib.h
- From: Alexander Gladysh <agladysh@...>
- Date: Wed, 17 Nov 2010 17:00:27 +0300
On Wed, Nov 17, 2010 at 12:23, Fabien <email@example.com> wrote:
> Hi, let's start suggestions for Lua 5.3 :)
> the functions provided by lauxlib.h generally have quite generic purposes,
> yet have a luaL_* prefix instead of lua_*. I realize it might have made
> sense when lauxlib was a fresh addition, but from a usability point of view,
> I don't see what I get in exchange of having to remember which function
> starts with luaL vs. which one starts with just lua.
> Are there reasons to keep this that way, apart from backward compatibility
> concerns which could be addressed through a set of macros?
The separation is very clear as I remember. luaL_ functions can be
(and are) implemented in terms of lua_ ones.
That L letter is the excuse to allow "bloating" Lua API with useful
functions. "If you need to get smaller, throw them away".
Your suggestion will only lead Lua team to throwing luaL_ functions
away, telling us: "implement them yourselves if you need them, that's
trivial". Please don't. :-)
At least that's how I understand the situation.