lua-users home
lua-l archive

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

On 8/13/07, Tony Finch <> wrote:
> Microsoft calls coroutines "fibres".

In that case I withdraw the suggestion!  ;)

Even though I'd like to see clearer language in the Lua docs, having
pondered it a bit more I would be very reluctant to adopt a neologism
like fiber.  Terminology proliferation is a bit like feature creep,
plus you run the risk of incurring cuteness penalties; "fiber" looks a
tad too precious for my taste.  I'm leaning strongly towards plain old
"non-preemptive thread" if we must.  It's too late now, but if I could
redesign Lua's lexicon I would make "coroutine" the name of the
datatype that is currently named "thread".  "function" is a type; why
not "coroutine"?  The term "thread" could then be used in the informal
expository prose explaining what a coroutine is.