lua-users home
lua-l archive

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Based on discussions in this thread, I've added a new section to the first article, clarifying where context switching happens, and why it's important to have a function naming convention that clearly marks these in the code.  The naming convention has also been changed, from async_ to await_, to emphasize the caller's point of view, while avoiding awkward names like "async_wait()".