(a) the status quo is bad;
Yes. I prefer "local-by-default for all within chunk".
(b) we need a way to specify whether a variable is global;
Yes. For example, by "global" keyword. Instead a current "local".
(c) one such way is to put a dollar sign in front of the name.
No! Please!! it's extremely bad!!!