lua-users home
lua-l archive

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Luiz Henrique de Figueiredo wrote:
I'm wondering why they can't just be named "and", "or" etc. Can the
I would much prefer that as well, but I do not see how it makes a lot
of difference in this case, as surely when you need bitops, the first
thing you do is

   local band = bit32.AND

That was exactly my point. Taco was much more successful in getting it across succinctly and clearly, thanks!

Except for the case of us embedded guys running highly memory
constrained systems.

I've got 64K total RAM of which maybe 48K is available before Lua
even starts up on my LEGO MINDSTORMS pbLua port.

I had one user that started wrapping all the drivers for the LEGO
hardware in a nice "object oriented" framework and he ran out
of memory before he even started writing an app.

Sometimes we want bare metal and no messing around.

All in all, if the worst thing I have to do is change all my
5.2-workX scripts from to bit32.AND - I'll take that hit.

I'd rather see of course, but those calls are going to
be down low in things like CRC generators, not up in high level
code (I hope)