lua-users home
lua-l archive

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Am 23.11.2013 08:13 schröbte luciano de souza:
Hello all,


I'd like to use a HTML parser. Searching on web, I found a rock called
htmlparser. As I used Lua 5.1 and htmlparser is compatible with lua
5.2, I did:

sudo apt-get purge lua5.1
sudo apt-get install lua5.2

You will also need:

    sudo apt-get install liblua5.2-dev

and you don't need to purge lua5.1 to install/use lua5.2 ...

sudo apt-get install luarocks

... and luarocks pulls lua5.1 back in anyway!

sudo luarocks install htmlparser

However, the result of this command was:

Missing dependences for htmlparser
lua >= 5.2
set >= 0.1

The LuaRocks version in the Ubuntu/Debian repositories is too old and only supports lua5.1. Try installing a more recent version manually. I use something like

    tar xzf luarocks-2.1.1.tar.gz
    cd luarocks-2.1.1
./configure --prefix=/home/siffiejoe/programs/luarocks --lua-version=5.2 --lua-suffix=5.2 --with-lua-include=/usr/include/lua5.2 --versioned-rocks-dir --force-config
    make bootstrap

to create a local LuaRocks installation in my home directory.

Yes, the installed version of Lua is really 5.. I don't know what
means "set >= 0.1" and I don't know what occurs.

Does someone have any idea?

I am using Lua 5.2 with ubuntu 13.10.