lua-users home
lua-l archive

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Ross Bencina <> writes:
> naming seems logical to be except for:
> callable() -> is_callable()

Both names are equally reasonable.

Which is preferable depends on the overall naming conventions -- if all
predicates tend to be called "is_..." then this one should be as
well.  This code seems to have only one other predicate, and it
doesn't use "is_...".

[Which brings to mind another issue:  if there's really a goal with
making a "standard Lua" library, things like naming conventions should
probably try to follow what Lua itself does.  Of course, I'm not sure
the base Lua even has _any_ predicates in it, so it's not clear how
it would]


Vote, v. The instrument and symbol of a freeman's power to make a fool of
himself and a wreck of his country.