lua-users home
lua-l archive

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

wini a écrit :
David and I have worked on the new LSP plugin for our web-server and we have been discussing the variable naming convention for some time. I would like to have a dialog with this group as to what is the best naming convention.

There is a "best" naming convention per programmer, I think...
Some will advocate encode_redirect_url, others like me EncodeRedirectURL, others EncodeRedirectUrl or encodeRedirectURL, or even Encode_Redirect_URL (I saw that!).

The "all lowercase" option isn't very readable, indeed (encode, encoder?).

Well, the best naming convention is probably just one you find readable, and that is applied _consistently_ across the project.

Philippe Lhoste
--  (near) Paris -- France
--  --  --  --  --  --  --  --  --  --  --  --  --  --