lua-users home
lua-l archive

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

On 20 June 2012 06:32, Pavel Holejsovsky <> wrote:
> Hello Lua hackers,
> lgi 0.6.1 was released.  As usual, it is available either
> from its github homepage[1], [2], luarocks (by 'luarocks install lgi'),
> or it might be available in your favorite distribution.
> lgi is gobject-introspection based dynamic Lua binding to GObject
> libraries. It allows using GObject-based libraries directly from Lua. If
> it sounds gibberish to you, ten simply said it allows easy usage of GTK+
> and similar libraries from Lua.
> This is bugfix release, no new major features were added compared to last
> 0.6 release.  List of fixed bugs taken from README is appended at the end
> of this announcement.
> Any comments or other feedback will be greatly appreciated, use github
> issue tracker [3] for reporting bugs.
> Happy hacking!
> Pavel
> [1]
> [2]
> [3]
> 0.6.1 NEWS:
>    avoid leak caused by not calling g_value_unset() in some cases
>    objects and structs: actually implement '_type' property as documented
>    tests: Fix regression tests for less common platforms
>    Pango: Add a few missing overrides
>    cairo: Fix Context:user_to_device() family of methods.
>    GStreamer: Add support for transfer!=none for input objects. This is
> needed to avoid leaks caused by strange usage of transfer annotations of
> gstreamer-0.10
>    GStreamer: Add more missing overrides
>    GStreamer: Fix and improve samples
>    Various fixes for usecase when lua context with loaded lgi is closed
> and opened again
>    Gtk: Add missing Gtk.Builder:connect_signals() override


I just updated my RPM package to 0.6.1 and I'm getting this error when
trying to run any of the samples:

$ lua samples/gtk-demo/main.lua
lua: ./lgi/override/cairo.lua:565: attempt to index field '_module' (a
nil value)
stack traceback:
	./lgi/override/cairo.lua:565: in main chunk
	[C]: in function 'require'
	./lgi/namespace.lua:174: in function 'require'
	./lgi/namespace.lua:161: in function 'require'
	./lgi/namespace.lua:161: in function 'require'
	./lgi/namespace.lua:161: in function 'require'
	samples/gtk-demo/main.lua:31: in main chunk
	[C]: ?

I thought it might be something wrong with the package, but I get the
same (or similar) error if I compile lgi and run the samples from the
same directory too. It also happens for lgi 0.6 but not 0.5.

Are there any specific version requirements on GTK/GI?

I'm using: