lua-users home
lua-l archive

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]


while most of Lua is rather consistent with respect to itself (which
is good), there is one place where I feel that there is something that
would benefit from a changed:

The type of the object returned by coroutine.create should be called
"coroutine", not "thread".

I would find it more consistent to not speak of threads in the context
of coroutines; this would also "free" the word "thread" for use in a
"real" threading library, etc.

Regards, Colin