[Date Prev][Date Next][Thread Prev][Thread Next]
[Date Index]
[Thread Index]
- Subject: Re: ffi methods aliasing/renaming
- From: Mike Pall <mikelu-1107@...>
- Date: Sat, 16 Jul 2011 10:27:56 +0200
Gaspard Bucher wrote:
> I am considering using ffi for OpenGL, but I do not like the "gl" scoping
> redundancy:
>
> gl.glMatrixMode(gl.GL_PROJECTION)
>
> Is it possible to somehow alias the constants and method calls in order to
> have ?
>
> gl.MatrixMode(gl.PROJECTION)
ffi.cdef[[
void MatrixMode(GLenum mode) asm("glMatrixMode");
]]
--Mike