lua-users home
lua-l archive

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

hmm.. how about

    require 'lua5.0'

;) Just came in from "the forest", a week in a tent. Got a sober mind, I hope? ;)

Roberto Ierusalimschy kirjoitti 4.8.2005 kello 20.29:

What I'd want is a way to have a script say "I'm done for Lua 5.0
syntax, please consider that" and so.. This could then be used to
handle deprecated vs. "latest and greatest" syntax changes
consistently.  Also, it would grant the reader of the source to see,
which Lua is expected to be running it.

That seems nice. A simple scheme would be simply a function call
like   compatmode5_0() or something like that.

Should it control the "whole" compatibility at once or should it
control different issues independently?
(e.g., compatmode5_0("longstrings") would set compatibility only
for long strings/comments...)

-- Roberto