[Date Prev][Date Next][Thread Prev][Thread Next]
- Subject: Re: Regarding the name 'pairs'
- From: steve donovan <steve.j.donovan@...>
- Date: Wed, 9 Sep 2009 11:17:06 +0200
On Wed, Sep 9, 2009 at 11:05 AM, John Hind<firstname.lastname@example.org> wrote:
> I would prefer a single __iter metamethod with deeper language integration
> so we can write:
> for v in myobject do print(v) end
That does make more sense than generalized ipairs and pairs. I always
liked how this used to happen 'magically' in 5.0, although the reason
for the change was clear enough.