lua-users home
lua-l archive

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

> Added:
>   _PATH
>      New name for LUA_PATH (now deprecated) used by 'require'

We thought it was kind of useless a prefix "LUA" for a Lua variable.
And Lua has a rule that its special variables should start with
underscore followed by uppercase letters. So _PATH seems more
appropriate. (But require still checks whether LUA_PATH exists,
to keep compatibility.)

>   load
>      No idea what this does. ^_^

Like loadfile and loadstring, but gets a function that should return
the chunk pieces.

-- Roberto