lua-users home
lua-l archive

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

It was thus said that the Great Alexander Schulz once stated:
> The main problems on using packages often are the dependencies and their
> management. For example almost all package managers force you to define a
> required version for a package. My experience is that in most cases the
> packages are just defining the minimum version and ignore a maximum
> version where the code compiles or runs correctly. I unterstand the
> motivation but it breaks my code so often - it really hurts.

  I'm not sure what you are saying here.  At the one extream, you can

	dependencies =
	  "lua" -- any version of Lua, even 1.0!

and at the other end:

	dependencies =
	  "lua >= 5.1, < 5.4"

If you stuff really is zero dependency functions, then what's the problem
with specifying "lua >= 5.1, < 5.4" (where Lua 5.4 doesn't exist yet)?