So I would like what you usually prefer before I'm going further in my
project because it will require a lot of these kind of calls :-).
While I feel smarter/clever when using the second variety, the first is much clearer.
I will say that my answer is tempered with the slight pause I feel whenever I put something other than "pairs" or "ipairs" as the iterator. That isn't a reason not to do it. I'm only trying to give you complete feedback.