I prefer 2, since it seems closer to the meaning and therefore more intuitive. But does it really need a patch?
Yea, it seems 2 works right now ;)
function f(x,y or 0)
function f(x,y) y=y or 0
Neither would break existing code.
Which of the above should I choose to implement as a patch?