lua-users home
lua-l archive

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

On Sat, Nov 27, 2010 at 07:02:20PM +0300, Alexander Gladysh wrote:

> > It's a debugging function. it's very implementation-specific. It
> > belongs with other debugging functions. It's overkill to make a new
> > namespace for a single function.
> It is much worse to change standard namespace.
> What if somebody else will make a function with the same name but
> other semantics?

The same as if that same somebody else uses the same namespace as this
change might; the user gets to keep all the pieces.