lua-users home
lua-l archive

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

That was confirmed as the source of Charlie's problem.

On Mon, 07 Jun 2010 16:23:50 -0700, Stuart P. Bentley <> wrote:

Deleting and re-installing my Lua for Windows installation on my tablet fixed it.

One problem that I ran into, and I suspect it's the same one Charlie's running into, though I haven't confirmed it yet, is that you must run the command prompt as an Administrator. I'm always on as Administrator on my desktop, but on my tablet I keep UAC higher. "Error unpacking rock file" is endemic of the install command being run from a LUA (Limited User Account - one of the few times that's been used correctly on this list) privileged prompt. This should probably be included in the installation steps- I'll add it now.

On Mon, 07 Jun 2010 10:25:34 -0700, Fabio Mascarenhas <> wrote:

Hi, Stuart,

I just downloaded LfW 5.1.4-37, installed it, then downloaded from and copied
the contents of the .zip file to where I installed LfW. "luarocks
install wsapi-xavante" ran with no problems. Could you check where
your LUA_DEV environment variable and your PATH are pointing? Maybe an
older version of LuaRocks and/or LfW are conflicting with our newest
installation (and the same can be happening with your friend).

Fabio Mascarenhas

On Mon, Jun 7, 2010 at 7:33 AM, Stuart P. Bentley <> wrote:
After extracting the LuaRocks for LfW zip over my desktop's LfW 5.1.4-34 installation, I was able to install wsapi-xavante just fine. However, my friend who extracted it over his LfW 5.1.4-35 installation had this error:

C:\Users\Charlie>luarocks install wsapi-xavante

Error: Failed unpacking rock file:

(Also, his changes.txt file says 5.1.4-34 at the beginning of the 5.1.4-35
changes section.)

On my tablet running LuaRocks extracted over Lua for Windows 5.1.4-37, I get
this error:

C:\Users\Stuart>luarocks install wsapi-xavante

Missing dependencies for wsapi-xavante:
xavante >= 2.2.0
rings >= 1.2.3
wsapi >= 1.3.4
coxpcall >= 1.13

Missing dependencies for xavante:
copas >= 1.1.5

Missing dependencies for copas:
coxpcall >= 1.13

Error: Failed installing dependency:
nte-2.2.0-1.all.rock - Failed installing dependency:
ories/rocks/copas-1.1.6-1.all.rock - Failed installing dependency:
http://luaroc - File already exists:
rogram Files (x86)\Lua\5.1\lua/coxpcall.lua