lua-users home
lua-l archive

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

On Mon, May 11, 2009 at 8:41 AM, steve donovan
<> wrote:

>> 2) Include all table operations. One should be able to write L:concat('\t'), not
>>   table.concat(L, '\t')
> Now that is something I've been considering, although that particular
> operation is now L;join '\n', which may be confusing. Mixing up my
> languages?

Yes i did notice, but I think there is a point to List being a true
superset of table

>> 3) Related to the above, methods *really* should have the same meaning as the
>>   table operation of the same name. L:remove(2) should not be
>> something completely  different from table.remove(L, 2)! I appreciate the python
>> heritage, but this is Lua after all
> Yes, exactly. List was intended to reproduce the Python interface, and
> remove has a very definite meaning in Lua. Perhaps the current meaning
> should be expressed as L:remove_value(2) ?

I renamed it to 'purge' in my patch, but an explicit wording may be
better then just another arbitrary synonym for sure.

> Thanks, I'm deep into the next release cycle, and this is exactly the
> kind of feedback I need. pretty.write is currently irritating me, and
> I'm trying for something really pretty, like:
> {
>  {1,2,3},
>  {3,4,5}
> }
> instead of throwing in all those linefeeds.

Sounds good. I will be looking forward to that.
The hard part is to determine when the compact and the verbose format
is the more appropriate, yes ?