lua-users home
lua-l archive

[Date Prev][Date Next][Thread Prev][Thread Next] [Date Index] [Thread Index]

Couldn't we have both as math.mod and math.mod2 well documented and just state which one is %? Of course for compatibility, the old one cannot change...


Adam D. Moss escreveu:
The % version seems much more correct to me, though
I'd rather the two implementations were consistant.
On the other hand changing the behaviour of math.mod
to be a modulus instead of remainder operation could
subtly break some old code.  Ho hum.

p.s. sieve.lua is around 12% faster with % instead
of math.mod() :)