[Date Prev][Date Next][Thread Prev][Thread Next]
- Subject: Re: luaL_verror
- From: Roberto Ierusalimschy <roberto@...>
- Date: Mon, 09 Aug 1999 09:57:57 -0300
> With only a few more lines we'd have both flavours and could use
> luaL_verrorf() to build more fancy error handlers.
All functions in lauxlib.c can be written "outside" Lua, as they do not use
any inside information. This library exists only because Lua itself needs
those functions. Because Lua does not use a "luaL_verrorf" function, there
is no point in putting it inside lauxlib.c. It is easy for those who
need it to write it (as you did); those who do not need it do not have to
pay for it. Moreover, an implementation with a fixed buffer of 500 chars
is what Lua needs, but may not be exactly what other people need.
> At least lua_verror is misnamed as it takes ... and not va_list it
> should be named lua_errorf.
You are right.